Linux下 FFmpeg 编译安装

更新于2018-04-02,如已失效请联系!
FFmpeg是一套可以用来记录、转换数字音频、视频,并能将其转化为流的开源计算机程序。
官网:http://ffmpeg.org

1、FFmpeg 安装

1.1、安装依赖包

1.2、FFmpeg编译安装

由于系统不同,会导致依赖也不尽相同,需根据报错信息逐渐安装依赖:

1.3、成功安装之后,查看版本:

1.4、转码:

2、FFmpeg安装错误解决

2.1、报错:yasm/nasm not found or too old. Use –disable-yasm for a crippled build

2.2、报错:ERROR: libfdk_aac not found

2.3、报错:ERROR: libvorbis not found

2.4、报错:ERROR: libmp3lame >= 3.98.3 not found

2.5、报错:ERROR: libx264 not found

2.6、报错:ERROR: libxvid not found

2.7、库文件找不到时解决

2.8、参考文档

https://my.oschina.net/u/998693/blog/406997
http://www.lenky.info/archives/2013/10/2349
http://blog.sina.com.cn/s/blog_61bc01360102w815.html
http://java-er.com/blog/linux-installffmpeg/

相关文章

参与评论